В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Сutie2004
Сutie2004
26.07.2022 04:23 •  Информатика

Составить программу, которая считает в формуле, заданной с клавиатуры, количество открывающихся и закрывающихся круглых скобок

Показать ответ
Ответ:
Danil545849
Danil545849
23.05.2020 15:18

Pascal:

 

program strings;

uses crt;

var i,open,close:integer;

a:String;

begin

open:=0;

end:=0;

clrscr;

write('Введите строку: '); readln(a);

for i:=1 to length(a) do

begin

if a[i]='(' then open:=open+1;

if a[i]=')' then close:=close+1;

end;

 

writeln('Открывающихся скобок: ', open, ' штук');

writeln('Закрывающихся скобок: ', close, ' штук');

readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота