В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Merser2212
Merser2212
22.08.2021 16:00 •  Информатика

Составить программу которая считывает целое число. если оно чётное и положительно увеличить его в два раз , в противном случае увеличить в 10 раз.

Показать ответ
Ответ:
lerabutsenko
lerabutsenko
26.08.2020 22:29
C#:
    class Program
    {
        static void Main(string[] args)
        {
            int a;
            a = Convert.ToInt32(Console.ReadLine());
            if (a % 2 == 0)
            {
                a *= 2;
            }
            else
            {
                a *= 10;
            }
            Console.WriteLine(a);

            Console.ReadLine();
        }
    }

Pascal:

program n;
var
a: integer;
begin
readln(a);
if a mod 2 = 0 then
a *= 2
else
a *= 10;
writeln(a);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота