В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Составить программу которая сформирует целочисленный массив из n элементов и увеличит все элементы массива на значение максимального элемента. требования : n - не более заполнения массива - ввод значений с клавиатуры; наличие в массиве положительных и отрицательных элементов; вывод сопровождается: исходный массив, значение максимального элемента, печать массива после внесенных в него изменений, дружественный интерфейс

Показать ответ
Ответ:
kate832
kate832
08.10.2020 00:09
var a: array[1..999] of integer;
var n, max: integer;
begin   
read(n);
    for var i := 1 to n do begin 
       read(a[i]); 
   end;   
for var i := 1 to n do begin   
    if a[i+1] > a[i] then 
      max := a[i+1];   
    write(a[i] + ' '); 
       if i = n then writeln;
    end;   
 writeln(max); 
  for var i := 1 to n do begin
      a[i] += max;   
      write(a[i] + ' '); 
  end;
end.
Составить программу которая сформирует целочисленный массив из n элементов и увеличит все элементы м
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота