В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Sozedatel
Sozedatel
26.05.2020 23:23 •  Информатика

Составить программу которая строит изображение предмета в плоском зеркале (расстояние от предмета до зеркала вводиться с клавиатуры).

Показать ответ
Ответ:
Evelina0889
Evelina0889
24.05.2020 02:15

Картинка должна быть в папке с программой и быть в формате BMP

uses
graphabc;

var
n: string;
b: Picture;
s:integer;

begin
writeln('введите расстояние до зеркала');
readln(s);
write('Введите имя файла рисунка: ');
readln(n);
window.Clear;
b := Picture.Create(n);
b.Load(n);
b.Draw(50, 50);
b.FlipHorizontal;
b.Draw(50+2*s,50);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота