В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Fox332
Fox332
27.07.2020 18:57 •  Информатика

Составить программу, которая требует ввести с клавиатуры координаты точки на плоскости (x,y - действительные числа) и определяет принадлежность точки заштрихованной области, включая ее границы (Сделать 12 вариант в C++)


Составить программу, которая требует ввести с клавиатуры координаты точки на плоскости (x,y - действ

Показать ответ
Ответ:
Дмитрий308228
Дмитрий308228
16.11.2022 01:52
//Dev-C++ 5.11

#include <stdio.h>
int main(void)
 {float a[10][10]={0},newar[100]={0},min=2147483647;
 int i,j,n,c,coucurr=1,newn=0,boo=0;
 scanf("%d",&n);
 for(i=0;i<n;i++)
  for(j=0;j<n;j++)
   {scanf("%f",&a[i][j]);
   newar[newn]=a[i][j];
   newn++;}
 for(i=0;i<newn;i++)
  {for(j=0;j<newn;j++)
   if (newar[i]==newar[j] && i!=j)
    coucurr++;
  if (coucurr>1 && min>newar[i])
   {min=newar[i]; boo=1;}
  coucurr=1;}
if(boo)
 printf("%f",min);
else
 printf("Nothing");
 return 0;}

Пример ввода:
3
1
2
2
3
3
3
4
4
4
Пример вывода:
2
0,0(0 оценок)
Ответ:
jonjonson
jonjonson
27.06.2021 19:21
Const n=5;
var a:array[1..n,1..n] of integer;
i,j,s1,s2:integer;
b:boolean;
begin
for i:=1 to n do
 for j:=1 to n do read(a[i,j]);b:=true;
s1:=0;
for j:=1 to n do s1:=s1+a[1,j];
for i:=1 to n do
 begin
 s2:=0;
 for j:=1 to n do s2:=s2+a[i,j];
 if s1<>s2 then b:=false;
 s2:=0;
 for j:=1 to n do s2:=s2+a[j,i];
 if s1<>s2 then b:=false;
 end;
if b then writeln('Матрица - магический квадрат')
     else writeln('Матрица не является магическим квадратом');
end.

Пример 1:

17 24 1 8 15
23 5 7 14 16
4 6 13 20 22
10 12 19 21 3
11 18 25 2 9Матрица - магический квадрат

Пример 2:
15 24 1 8 17
5 23 7 14 16
22 4 6 13 20
10 12 19 21 3
11 18 2 25 9
Матрица не является магическим квадратом
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота