В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
tanysha4957
tanysha4957
10.08.2021 23:46 •  Информатика

Составить программу, которая в одномерном массиве размерностью 15, состоящим из случайных чисел из промежутка от 20 до 80,находится наибольший элемент оканчивающийся на цифру 2 или 8

Показать ответ
Ответ:
minzer
minzer
27.08.2020 13:52

var a: array[1..15] of integer;

i,m: integer;

begin

writeln('массив:');

for i:=1 to 15 do

begin

a[i]:=random(61)+20;

write(a[i],' ');

end;

m:=-1;

writeln;

for i:=1 to 15 do

if ((a[i] mod 10=2) or (a[i] mod 10=8)) and (a[i]>m) then m:=a[i];

if m=-1 then write('такого элемента нет') else writeln('m=',m);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота