В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
petrovspb
petrovspb
03.05.2022 23:38 •  Информатика

Составить программу которая в предложении взвейтесь кострами ночи синие поменяет местами последние слова и посчитает количество слов в предложении

Показать ответ
Ответ:
лох252
лох252
17.04.2023 13:42
Var
    n, k, i, imax, j: integer;
    a: array[1..100]of integer;

begin
    randomize;
    n := random(30) + 10;
    for i := 1 to n do
    begin
        a[i] := Random(30);
        write(a[i], ' ');
    end;
    writeln();
   
    {сортировочка}
    for i := 1 to n - 1 do
    begin
        imax := i;
        for j := i + 1 to n do
            if a[j] > a[imax] then
                imax := j;
        k := a[i];
        a[i] := a[imax];
        a[imax] := k;
    end;
   
    for i := 1 to n do
        write(a[i], ' ');
   
    k := 0;
    for i := 2 to n - 1 do
        if (a[i] <> a[i - 1]) and (a[i] <> a[i + 1]) then
            k := k + 1;
   
    if a[1] <> a[2] then k := k + 1;
    if a[n] <> a[n - 1] then k := k + 1;
   
    writeln();
    writeln('No doubles - ', k);
end.
0,0(0 оценок)
Ответ:
Rashid200413
Rashid200413
21.04.2022 02:29
Var
i,j,k:longint;
    begin
         for i:=1 to 1000 do
              for j:=1 to 1000 do       
                   for k:=1 to 10000 do             
                      if sqr(i)+sqr(j)=sqr(K)then               
                           begin                 
                                writeln(i,' ',j,' ',k);  {вывожу все тройки, можно убрать}             
                                     if i+j+k=1000 then                 
                                          begin                 
                                               writeln('! ',i,' ',j,' ',k);  {нужная тройка}                
                                                exit; {прерывание программы}                
                                          end;               
                           end;   
     end.


Существуют тройки пифагора, то есть a^2+b^2=c^2 . есть лишь одна такая тройка, что a+b+c=1000 . напи
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота