В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
sebtetfGек5у
sebtetfGек5у
15.11.2021 00:47 •  Информатика

Составить программу которая возводит в 3 степень положительные элементы массива а15 и выводит модуль числа отрицательного элемента этого массива

Показать ответ
Ответ:
Korolinaaa
Korolinaaa
23.01.2021 20:38

program z1;

var i:integer;

a:array[1..15] of integer;

begin

for i := 1 to 15 do

begin

a[i]:=random (11) - 5;

write (a[i]:5)

end;

writeln;

for i := 1 to 15 do

begin

if a[i] > 0 then a[i]:=sqr(a[i])*a[i];

if a[i] < 0 then a[i]:=abs(a[i]);

write (a[i]:5)

end

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота