В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
15.05.2021 05:53 •  Информатика

Составить программу которая вводит с клавиатуры четыре целых числа a,b,c,d (каждое число - отдельной командой "ввод") и выводит на экране минимальное среди них.ничего кроме этого программа выводить не должна. при использовании системы free pascal для представления целых чисел используйте тип longint. надо сделать в pascal

Показать ответ
Ответ:
Alexa647
Alexa647
11.06.2020 19:23

var

  a, b, c, d, t1, t2:longint;

begin

  write('a = '); readln(a);

  write('b = '); readln(b);

  write('c = '); readln(c);

  write('d = '); readln(d);

  if a < b then

    t1 := a

  else

    t1 := b;

  if c < d then

    t2 := c

  else

    t2 := d;

  if t1 < t2 then

    writeln('Min = ', t1)

 else

    writeln('Min = ', t2);

  readln;

end.

 

0,0(0 оценок)
Ответ:
яя82
яя82
11.06.2020 19:23

var

a,b,c,d,max:longint;

begin

  read(a); read(b); read(c); read(d);

  min:=a;

  if min>b then min:=b;

  if min>c then min:=c;

  if min>d then min:=d;

  writeln(min);

end.

 

Программа работает, проверено мной.)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота