В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
morpeh4575
morpeh4575
22.06.2020 22:09 •  Информатика

Составить программу, которая вычисляет площадь треугольника заданного координатами своих вершин. используя формулу герона. вычисления расстояния между двумя точками оформить в виде процедуры или функции

Показать ответ
Ответ:
полли43
полли43
09.10.2020 19:18

Попроси решение у одноклассников и просто поменяй название переменных. Я сам так всегда делаю

Решение

Program n1;

Procedure qwe(x1,x2,y1,y2:integer);

var a,b,c,p:real;

begin

a:= x2-x1;

b:= y2-y1;

c:= sqrt((a*a)+(b*b));

p:=(a+b+c)/2;

writeln(sqrt(p*(p-a)*(p-b)*(p-c)));

end;

var i,o,p,l:integer;

begin

read(i,o,p,l);

//Вводить в формате x1,x2,y1,y2

qwe(i,o,p,l);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота