Составить программу, которая вычисляет стоимость покупки товаров одного типа с учетом скидок на некоторые группы товаров (группы имеют коды) и скидку 5%, если общая сумма покупки составляет более 100 грн.
Скидки на некоторые группы товаров с кодами от 100 до 500: 100...150 - 2%, 210, 215, 220 - 7%, 230...300 - 9%. Если код группы товаров не относится к указанным, то вывести сообщение об отсутствии скидок. Программа Python
В восьмиричной системе: разбиваете двоичное представление на группы по 3 бита справа налево
011 = 3
011 = 3
011 = 3
10 = 2
Тогда в восьмиричной системе: 2333(8) = 2*8^3+3*8^2+3*8^1+3 = 1024+192+24+3=1243(10)
В шестнадцатиричной системе: разбиваете двоичное представление на группы по 4 бита справа налево
1011 = B = 11(10)
1101 = D(16) = 13(10)
100 = 4
Тогда в шестнадцатиричной системе
4DB(16) = 4*16^2+13*16^1+11 =1024+208+11=1243(10)
z:string[10];
x:string[2];
i,j,k,m: integer; //новые переменные
Begin
Write('введите строку текста - St');
Readln(St);
k:=0; //обнуляем на всякий случай
z:='0123456789';
i:=1;
for j:=1 to length(St) do //начало
begin;
for m:=1 to 10 do
if St[j]=z[m] then inc(k);
end;
if k=0 then
begin;
writeln('в тексте нет цифр');
exit;
end; //конец
while i<=length(st)-1 do
begin
x:=copy(st,I,2);
if (x[1]=x[2]) and (pos(x[1],z)<>0) then
begin
delete(st,i,2);
insert('две',st,i);
i:=i+1;
end;
i:=i+1;
end;
writeln('преобразованная строка ', st);
End.