В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ольга1525
ольга1525
11.02.2020 10:55 •  Информатика

Составить программу, которая вычисляет сумму и среднее арифметическое положительных чисел.

Показать ответ
Ответ:
Frosterion
Frosterion
14.10.2020 23:00

Для начала каких чисел?

Они вводятся или нет?

Ох, ладно

Допустим, вводятся)

Python

Я ввожу число и все положительные числа, которые входят в него будут проходить через программу...

n = int(input())

g = 0

l = 0

for i in range(n+1):

   g += 1

   l += i

g -= 1

print( l // g )

Пример

Ввод: 5

Вывод: 3

Как получилось:

1+2+3+4+5=15

кол-во цифр = 5

15 / 5 =3

Как-то так

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота