В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
megabobr11
megabobr11
15.03.2021 18:46 •  Информатика

Составить программу, которая вычисляет сумму отрицательных элементов одномерного массива вещественных чисел, состоящего из 7 элементов. Заполнить массив вводом с клавиатуры. на языке С++

Показать ответ
Ответ:
Max04032003
Max04032003
16.10.2022 02:51

1.1.   Процессор (CPU) Микропроцессор — устройство, отвечающее за выполнение арифметических, логических и операций управления, записанных в машинном коде, реализованный в виде одной микросхемы. В настоящее время наиболее широкое распространение получили платы компаний Intel и AMD, которые различаются по стоимости, производительности, и количеству ядер (1, 2, 4, 6, 8).

1.2.   Системная плата Материнская плата (англ. motherboard, MB, также используется название англ. mainboard — главная плата) — это сложная многослойная печатная плата, на которой устанавливаются основные компоненты персонального компьютера. Как правило, материнская плата содержит разъёмы (слоты) для подключения дополнительных контроллеров, для подключения которых обычно используются шины USB, PCI и PCI-Express.

1.3.   Оперативная память Оперативная память (также оперативное запоминающее устройство, ОЗУ) предназначена для временного хранения данных и команд, необходимых процессору для выполнения им операций. Виды оперативной памяти: DDR - является самым старым видом оперативной памяти, которую можно еще сегодня купить. Рабочее напряжение DDR - 2.5 вольт (обычно увеличивается при разгоне процессора), и является наибольшим потребителем электроэнергии из рассматриваемых видов памяти. DDR2 - это наиболее распространенный вид памяти, который используется в современных компьютерах. Это не самый старый, но и не новейший вид оперативной памяти.  DDR3 - быстрый и новый тип памяти. Все три вида памяти не совместимы друг с другом!

1.4.   Видеокарта Видеокарта (известна также как графическая плата, графическая карта, видеоадаптер) (англ. videocard) — устройство, преобразующее изображение, находящееся в памяти компьютера, в видеосигнал для монитора. Дополнительная видеокарта необходима лишь при условии, что ПК используется для обработки сложной графики.

1.5.   Жесткий диск Накопитель на жёстких магнитных дисках, НЖМД, жёсткий диск, винт, хард, харддиск, HDD — энергонезависимое, перезаписываемое компьютерное запоминающее устройство. Является основным накопителем данных практически во всех современных компьютерах. При выборе жесткого диска необходимо учитывать его интерфейс. В настоящее время наиболее распространен интерфейс SATA, но для модернизации старых ПК необходимо использовать жесткий диск с интерфейсом IDE. С целью увеличения производительности и надежности хранения информации, возможна установка в ПК нескольких жестких дисков.

1.6.   Звуковая карта З вуковая плата (также называемая звуковая карта или музыкальная плата) (англ. sound card) — это плата, которая позволяет работать со звуком на компьютере. В настоящее время звуковые карты бывают как встроенными в материнскую плату, так и отдельными платами расширения или как внешними устройствами

1.7.   Накопители и носители информации Диске́та - портативный магнитный носитель информации, используемый для многократной записи и хранения данных сравнительно небольшого объема. Этот вид носителя был особенно распространён в 1970-1990гг Диски оптические (CD, DVD ) В качестве носителей оптический привод использует плоские многослойные диски диаметром 8 или 12 см. При заказе дисков необходимо обращать внимание на тот тип устройства чтения/записи (привод), установленный в вашем ПК U SBFlashDrive - носитель информации, используемый для хранения, переноса и обмена данными, резервного копирования и др. Подключается к компьютеру или иному считывающему устройству через стандартный разъём USB. Возможна ситуация когда устройство автоматически не определяется на компьютерах с операционной системой Windows 95, 98, Me, NT, 2000 , тогда необходимо дополнительно устанавливать драйвера. Если флеш не работает при включении в USB разъем на лицевой панели системного блока, подключите ее в любой USB разъем с тыльной стороны системного блока (рис.1). В основном в настоящее время используются накопители на 2, 4 и 8 Gb.

1.8.   Оптический привод ( rewriter) – устройство чтения, записи дисков Можно выделить несколько основных типов данных устройств: CD-ROM - данный привод читать только обычные CD. CD-RW - CD-RW позволяет не только считывать информацию с обычных компакт-дисков, но и записывать её на CD-R и CD-RW. DVD-ROM - устройство читать компакт-диски DVD. DVD-CD-RW Combo - так называемый Combo-драйв, который сочетает в себе функции таких устройств, как DVD-ROM и CD-RW и, соответственно, может записывать диски CD-R и CD-RW, считывать как обычные CD, так и DVD. DVD-RW –позволяет не только читать диски CD/DVD, но и записывать как обычные CD-R/CD-RW-носители, так и куда более ёмкие DVD-R/DVD-RW/DVD+R/DVD+RW. Blu -Ray, BD (blue ray — синий луч) — формат оптического носителя, используемый для записи и хранения цифровых данных, включая видео высокой чёткости с повышенной плотностью. Однослойный диск Blu-ray (BD) может хранить 23,3/25/27 или 33 Гб, двухслойный диск может вместить 46,6/50/54 или 66 Гб.

Подробнее: https://hotuser.ru/usermanual/1823-2009-12-07-13-30-05

0,0(0 оценок)
Ответ:
lenichk
lenichk
31.03.2020 12:15
Var St: string;
 z:string[10];
 x:string[2];
i,j,k,m: integer;           //новые переменные
Begin
Write('введите строку текста - St');
Readln(St);
k:=0;                       //обнуляем на всякий случай
z:='0123456789';
i:=1;
for j:=1 to length(St) do //начало
 begin;
  for m:=1 to 10 do
   if St[j]=z[m] then inc(k);
 end;
if k=0 then
begin;
 writeln('в тексте нет цифр');
 exit;
end;                              //конец
while i<=length(st)-1 do
begin
x:=copy(st,I,2);
if (x[1]=x[2]) and (pos(x[1],z)<>0) then
begin
delete(st,i,2);
insert('две',st,i);
i:=i+1;
end;
i:=i+1;
end;
writeln('преобразованная строка ', st);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота