В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
darinashagaeva
darinashagaeva
27.08.2021 12:41 •  Информатика

Составить программу,которая выводит на экран коды введенных слов,затем меняет каждый символ с соседним и выводит полученный текст на экран

Показать ответ
Ответ:
jamshidbek
jamshidbek
06.08.2020 23:59
uses crt;
var c:char;
begin clrscr;
write('Введите символ ');
readln(c);
case c of '0'..'9':write('Это десятичная цифра, ее код ',ord(c)); 'A'..'Z':write('Это прописная латинская буква, ее код ',ord(c)); 'a'..'z':write('Это строчная латинская буква, ее код ',ord(c));
'+','-','*':write('Это знак арифметического действия, его код ',ord(c)); //убрал знак /, он в спец. символах ';','<','=','>','?','[',']','{','}','\','/':write('Это служебный символ, его код ',ord(c)); else write('Символ не входит в указанный список') end; readln end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота