В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
RDD1
RDD1
07.07.2020 16:26 •  Информатика

Составить программу которая выводит таблицу значений функции y 2x^2-x/5 на отрезке [-4;6] с шагом 1. Программа PascalABC

Показать ответ
Ответ:
neush
neush
13.03.2020 05:10
ответ: 1909

Var
 s : String;
 n : Integer;
Function IncS(a : String) : String;
Begin
  a[Length(a)]:=Chr(Ord(a[Length(a)])+1);
  If a[Length(a)]>'D' then
    IncS:=IncS(Copy(a,1,Length(a)-1))+'A'
  else IncS:=a;
end;
Function Check(a : String) : Boolean;
Begin
  Check:=False;
  If (Pos('A',a)>0) then
  Begin
    Delete(a,Pos('A',a),1);
    If (Pos('A',a)>0) then Check:=True;
  end;
end;
Begin
  s:=''; n:=0;
  While s<>'' do
  Begin
  {  Writeln(s);  }
    If Check(s) then Inc(n);
    s:=IncS(s);
  end;
  Writeln(n);
end.
0,0(0 оценок)
Ответ:
sembaevam
sembaevam
27.07.2022 09:30
// PascalABC.NET 3.0, сборка 1073
const
  sb='bcdfgjklmnpqrstvwxz';
  s='Computer programming is a process of computer programs creation';
var
  i,n:integer;
  s1,sn,t:string;
begin
  i:=1;
  while s[i]<>' ' do Inc(i);
  s1:=Copy(s,1,i-1);
  n:=Length(s); i:=n;
  while s[i]<>' ' do Dec(i);
  sn:=Copy(s,i+1,n-i);
  t:='';
  for i:=1 to Length(s1) do
    if Pos(s1[i],sb)>0 then t:=t+s1[i];
  s1:=t;
  t:='';
  for i:=1 to Length(sn) do
    if Pos(sn[i],sb)>0 then t:=t+sn[i];
  sn:=t;
  t:='';
  for i:=1 to Length(s1) do
    if Pos(s1[i],sn)>0 then
      if Pos(s1[i],t)=0 then t:=t+s1[i];
  for i:=1 to Length(t) do Write(t[i],' ');
  Writeln
end.
 
Тестовый прогон:
t r

2. "Нормальное" решение

// PascalABC.NET 3.0, сборка 1073
const
  sb='bcdfgjklmnpqrstvwxz';
  s='Computer programming is a process of computer programs creation';
begin
  var a:=s.ToWords(' ');
  a[0].Intersect(a[a.Length-1]).Where(x->Pos(x,sb)>0).Println(',')
end.

Тестовый прогон:
t,r
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота