В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Vladislava256
Vladislava256
22.04.2022 14:59 •  Информатика

Составить программу, которая задает массив А[5, 6] случайным образом из чисел от -10 до 10 , выводит его на экран и находит количество положительных элементов массива

Показать ответ
Ответ:
azolin56745674
azolin56745674
11.05.2023 04:02

using System;

namespace ConsoleApp1

{

   class Program

   {

       static void Main(string[] args)

       {

           double a, b, c;

           Console.WriteLine("Введите a:");

           a = Convert.ToDouble(Console.ReadLine());

           Console.WriteLine("Введите b:");

           b = Convert.ToDouble(Console.ReadLine());

           Console.WriteLine("Введите c:");

           c = Convert.ToDouble(Console.ReadLine());

           Console.Write("Результат: {0} , {1}, {2}", (a > 0) ? a * a : a * a * a * a,

               (b > 0) ? b * b : b * b * b * b, (c > 0) ? c * c : c * c * c * c);

       }

   }

}

0,0(0 оценок)
Ответ:
gusew7kaja
gusew7kaja
17.11.2021 19:27

Прости, я не могу это щас решить

Объяснение:

Берём например ip 210.171.30.128

Берем число 210 и начинаем делить на 2.

210 поделить на 2 равно 105 с остатком 0.

105 раздели на 2 равно 52 с остатком 1.

52 поделить на 2 выходит 26 с остатком 0.

26 поделим на 2 - получится 13 с остатком 0.

13 - 6 с остатком 1.

Делим 6 и получаем 3 с остатком 0.

3 на 2 - выходит 1 с остатком 1.

1 поделить на 2 - получается 0 с остатком 1.

Теперь записываем значение в обратном порядке (с конца): 11010010.

Прости, но тебе придётся самому решить

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота