В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Чертенок22
Чертенок22
22.02.2020 18:49 •  Информатика

Составить программу, которая заполнит массив 10 целыми случайными числами из промежутка [-10;10], отсортировать массив (любым методом), вывести полученный массив на экран и подсчитать количество отрицательных элементов.​

Показать ответ
Ответ:
Анюточка2906
Анюточка2906
01.03.2022 04:37

program pr10;

uses crt;

var

  i: integer;

  t: real; // рабочая переменная

  i: byte; // счетчик массива

  k: byte; // параметр цикла

  a: array[1..15] of real;

  n: byte; // размерность цикла

begin

  clrscr;

  write('введите размерность: ');

  readln(n);

  writeln('введите ',n,' элементов');

  for i: =1 to n do

      readln(a[i]);

      writeln('исходный массив: ');

  for i: =1 to n do

      write(a[i]: 5: 1,' ');

      readln;

// блок обработки

  for k: =1 to n do

      for i: =1 to n-k do

        if(a[i]> a[i+1]) then

// перестановка

            begin

              t: =a[i];

              a[i]: =a[i+1];

              a[i+1]: =t;

            end;

  writeln('отсортированный массив: ');

  for i: =1 to n do

      write(a[i],' ');

      writeln;

      readln;

end.

я хз как правильно проверить простое число или нет. вот код, который просто сортирует массив по возрастанию.  

0,0(0 оценок)
Ответ:
nocitronum
nocitronum
10.12.2021 09:52

type cl = class

  a: integer;

  constructor create(b: integer);

  procedure setval(b: integer);

  function getval: integer;

  procedure sq;

end;

constructor cl.create(b: integer);

begin

  a : = b;

end;

procedure cl.setval(b: integer);

begin

  a : = b;

end;

function cl.getval: integer;

begin

  getval : = a;

end;

procedure cl.sq;

begin

  if a < 0 then

    writeln('a ^ 2 = ', a * a)

  else

    writeln('error');

end;

var

  obj: cl;

  a : integer;

begin

  write('a = ');

  readln(a);

  obj : = cl.create(a);

  obj.sq;

  readln;

  obj.destroy;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота