В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
agentboy
agentboy
30.01.2021 22:16 •  Информатика

Составить программу, которая запоминает массив а () случайными числами от 1 о10 затем первый элемент меняет местами с максимальным элементом

Показать ответ
Ответ:
adelyavalieva1
adelyavalieva1
08.09.2020 12:16
Var
  a: array [1..10] of integer;
  i, max, s, x: integer;

begin
 s:=1;
  randomize;
  for i := 1 to 10 do
  begin
    a[i] := random(10) + 1
  end;
  writeln(a);
max := a[1];
 
  for i := 1 to 10 do
  begin
    if max < a[i] then begin
      max := a[i];
      s := i
    end;
  end; 
  x := a[1];
  a[1] := a[s];
  a[s] := x;
    writeln(a)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота