Составить программу, которая запрашивает целые числа до тех пор, пока их сумма не превысит 500.
(т.е. после запуска программы пользователя ввести число. Пользователь вводит число, и оно
добавляется к сумме введенных им ранее чисел. Как только это сумма превысит 500 программа должна
закончить свою работу и вывести на экран получившуюся суммы. ПАСКАЛЬ
DIM n AS INTEGER
INPUT "Введите кол-во студентов:", n
DIM studentYearsOld(1 TO n) AS INTEGER
DIM studentName(1 TO n) AS STRING
FOR i = 1 TO n
INPUT "Введите имя студента:", studentName(i)
INPUT "Введите год рождения студента:", studentYearsOld(i)
NEXT i
PRINT
FOR i = 1 TO n
PRINT "Студент "; studentName(i)
studentYrs = 2016 - studentYearsOld(i)
IF studentYrs < 18 THEN
PRINT "Лет до права голоса:"; 18 - studentYrs
ELSEIF studentYrs >= 18 THEN
PRINT "Студент уже имеет право голоса!"
PRINT
END IF
studentYrs = 0
NEXT i
Код валидный, если допустил ошибку во время переписывания - сообщите.
DIM tetradCount as INTEGER, oblojCount as INTEGER, price1 AS INTEGER, price2 AS INTEGER
CLS
INPUT "Введите кол-во тетрадей:"; tetradCount
INPUT "Введите кол-во обложек:"; oblojCount
price1 = tetradCount * 5
price2 = oblojCount * 3
PRINT "Стоимость тетрадей:"; price1
PRINT "Стоимость обложек:"; price2
PRINT "Общая стоимость:"; price1 + price2
END
C#:
Обычный класс, единственная директива препроцессора System, в методе main
int tetradCount, oblojCoubt, priceOne, priceTwo, priceSum;
Console.WriteLine("Введите кол-во тетрадей:");
tetradCount = int.Parse(Console.ReadLine());
Console.WriteLine("Введите кол-во обложек:");
oblojCount = int.Parse(Console.ReadLine());
priceOne = tetradCount * 5;
priceTwo = oblojCount * 3;
priceSum = priceOne + PriceTwo;
Console.WriteLine("Стоимость тетрадей: " + priceOne);
Console.WriteLine("Стоимость обложек: " + priceTwo);
Console.WriteLine("Общая стоимость: " + priceSum);