В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
kotgemer
kotgemer
12.11.2022 09:03 •  Информатика

Составить программу, которая запрашивает два числа и сообщает
наибольшее из них.

Показать ответ
Ответ:
aselkulmagambet
aselkulmagambet
15.09.2022 12:50
11100011110011100₂ = 11 100 011 110 011 100₂ = 343634₈
11100011110011100₂ = 1 1100 0111 1001 1100₂ = 1С79С₁₆

7351₈ = 111 011 101 001₂ = 111011101001₂
7351₁₀ / 2 = 3675, остаток 1
3675/2 = 1837, остаток 1
1837/2 = 918, остаток 1
918/2 = 459, остаток 0
459/2 = 229, остаток 1
229/2 = 114, остаток 1
114/2 = 57, остаток 0
57/2 = 28, остаток 1
28/2 = 14, остаток 0
14/2 = 7, остаток 0,
7/2 = 3, остаток 1
3/2 = 1, остаток 1
1/2 = 0, остаток 1
7531₁₀ = 11100101110111₂

А10BC1₁₆ - основание не указано, но скорее всего, оно и так  шестнадцатиричное и тут нечего переводить.

11100011110011100 - разобрать на восьмиричну и шестнадцатиричную систему числения. 7351 - разобрать
0,0(0 оценок)
Ответ:
E041Shvan
E041Shvan
25.11.2021 14:55

program d;

var min,max,a : integer;

mas:array[1..5] of integer;

begin

for a:=1 to 5 do

begin

readln(mas[a]);//вводим число и записываем его в массив

if mas[a]<=mas[min] then min:=a;//проверяем , если элемент массива меньше эталона , то запоминаем его индекс и перезаписываем эталон

if mas[a]>=mas[max] then max:=a;//проверяем , если элемент массива больше эталона , то запоминаем его индекс и перезаписываем эталон

end;

writeln;

writeln (mas[max]);//выводи элементм максимальный элемент

for a:=1 to 5 do

if (a<>min)and(a<>max) then writeln (mas[a]);//выводим все элементы кроме макс.и мин.

writeln(mas[min]);//выводим минимальный

end.​

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота