В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Treed1
Treed1
02.08.2022 05:46 •  Информатика

Составить программу, которая запрашивает координаты двух точек, а выводит длину отрезка, концами которого эти точки являются, и координаты середины этого отрезка. (блок систему и на языке паскаль)

Показать ответ
Ответ:
OlgaAlekseeBna
OlgaAlekseeBna
04.10.2020 20:39
Program Programma;
Uses crt;

var xA,xB,yA,yB,D: real;

Begin clrscr;
write('Введите координаты точки A через пробел: ');
readln(xA,yA);
write('Введите координаты точки B через пробел: ');
readln(xB,yB);

d:=sqrt(sqr(xA-xB)+sqr(yA-yB));
writeln;
write('Длина отрезака AB = ',d:0:3)
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота