В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
saidrasulov15
saidrasulov15
25.10.2021 19:40 •  Информатика

Составить программу которое забрашивает четырёхзначное число и находит сумму цифр четырёхзначного числа и определяет делиться на 5.​

Показать ответ
Ответ:
ура6
ура6
09.10.2020 05:25

program numsum;

uses

 SysUtils;

var

 n, i, sn: Integer;

 s: string;

begin

 Write ('Введите четырехзначное число: ');

 ReadLn (n);

 n := Abs (n);

 if (n > 9999) or (n < 1000) then begin

   WriteLn ('Введенное число не четырехзначное');

   ReadLn;

   Exit;

 end;

 s := IntToStr (n);

 sn := 0;

 for i := 1 to Length (s) do

   sn := sn + StrToInt (s [i]);

 WriteLn ('Сумма цифр числа = ', sn);

 if sn mod 5 = 0 then

   WriteLn ('Сумма цифр делится на 5')

 else

   WriteLn ('Сумма цифр не делится на 5');

 ReadLn;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота