В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
lidaat
lidaat
05.02.2021 14:20 •  Информатика

Составить программу на паскаль. слова могут содержать любые символы языка. найти и вывести в самом длинномслове все символы, отличные от заглавных латинских букв. использовать множества.

Показать ответ
Ответ:
var  
  a       : array of string;
  str, m: string;

begin
  readln(str);
  a := str.Split(' ');
  foreach str in a do
    if (m.Length < str.Length) then
      m := str;
  foreach kchr: char in m do
    if not (kchr in ['A'..'Z']) then
      write(kchr);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота