В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
moiseenkova041
moiseenkova041
20.04.2023 07:18 •  Информатика

Составить программу на паскале: ) для десяти чисел введенных с клавиатуры все отрицательные сложить а положительные умножить

Показать ответ
Ответ:
tsovinarjangiryan
tsovinarjangiryan
21.07.2020 16:59
Var a,b,c,d:integer;
beginwriteln('введите десять чисел');
readln(a);
b:=1;
d:=0;
for c:=2 to 10 do
begin
readln(a);
if (a > 0) then b:=b*a;
if (a < 0) then d:=d+a;
end;
writeln('положительные ',b);
writeln('отрицательные ',d)
end.
0,0(0 оценок)
Ответ:
anastaseyaaaa
anastaseyaaaa
21.07.2020 16:59
Const
  N = 10;

var
  x, i, minus, plus:integer;

begin
  plus:=-1;
  minus:=0;
  for i:=1 to N do
  begin
    readln(x);
    if x<0 then
      minus:=minus+x;
    if x>0 then
      if plus = -1 then      
        plus:=x
      else
        plus:=plus*x;
  end;
  writeln('Сумма отрицательных чисел: ', minus);
  if plus = -1 then
    writeln('Положительных чисел нет')
  else
   writeln('Произведение положительных чисел:', plus);
end. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота