Составить программу на Паскале для решения следующей задачи: программа запрашивает натуральное число от 1 до 10 (входящая переменная, например N) и выводит на экран таблицу умножения для данного числа.
Пример: задаём число 3
На экране должно отображаться:
3 * 1 = 3
3 * 2 = 6
3 * 3 = 9
3 * 4 = 12
3 * 5 = 15
3 * 6 = 18
3 * 7 = 21
3 * 8 = 24
3 * 9 = 27
3 * 10 = 30
var
a: array[1..15] of integer;
count,count_odd,num,sum,mult: integer;
begin
count := 1;
count_odd := 1;
num := 3;
sum := 0;
mult := 1;
while count <= 15 do
begin
a[count] := num;
count := count + 1;
num := num + 3;
end;
while count_odd <= 15 do
begin
sum := sum + a[count_odd];
mult := mult * a[count_odd];
count_odd := count_odd + 2;
end;
writeln('Массив из 15 элементов: 3, 6, 9, ..., 45');
writeln('Сумма элементов с нечетными индексами: ', sum);
writeln('Произведение элементов с нечетными индексами: ', mult);
end.
#include <cstring>
#include <vector>
#include <algorithm>
struct StudentData
{
std::string name;
std::string surname;
int math;
int phys;
int comp_science;
};
bool
comp(const StudentData &a, const StudentData &b)
{
int tmp1 = a.math + a.phys + a.comp_science;
int tmp2 = b.math + b.phys + b.comp_science;
return tmp1 > tmp2 ? true : false;
}
int
main(void)
{
int n;
std::cin >> n;
std::vector< StudentData > data(n);
for (int i = 0; i < n; i++) {
std::cin >> data[i].name >> data[i].surname;
std::cin >> data[i].math >> data[i].phys >> data[i].comp_science;
}
std::sort(data.begin(), data.end(), comp);
for (int i = 0; i < n; i++) {
std::cout << data[i].name << " " << data[i].surname << std::endl;
}
return 0;
}