Составить программу на паскале, которая формирует на экране изображение домика с закрашенной крышей, закрашенным прямоугольным окном и закрашенной ручкой на двери в форме круга . буду .
Вот: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 const n=5; var a: array[1..n,1..n] of integer; i,j,s: integer; begin s: =0; randomize; for i: =1 to n do begin for j: =1 to n do begin a[i,j]: =random(10); write(a[i,j]: 4); if (i+j) mod 3=0 then s: =s+a[i,j]; end; writeln; end; writeln('s=',s); end.
Количество информации определяется величиной, показывающей насколько уменьшилось наше незнание в вопросе. 1. Если на светофоре горит желтый свет и мы не знаем, какой свет горел на нем до желтого, то возможны два исхода - зеленый свет и красный свет. Какой бы из них потом не загорелся, мы получим выбор 1 из 2 возможных. А этому соответствует один бит информации. 2. Если на светофоре горит красный свет и это "нормальный светофор", то мы ЗНАЕМ, что после красного света всегда следует желтый. Поэтому при зажигании желтого света наше незнание не меняется, следовательно, мы получаем ноль бит информации.
1. Если на светофоре горит желтый свет и мы не знаем, какой свет горел на нем до желтого, то возможны два исхода - зеленый свет и красный свет. Какой бы из них потом не загорелся, мы получим выбор 1 из 2 возможных. А этому соответствует один бит информации.
2. Если на светофоре горит красный свет и это "нормальный светофор", то мы ЗНАЕМ, что после красного света всегда следует желтый. Поэтому при зажигании желтого света наше незнание не меняется, следовательно, мы получаем ноль бит информации.