В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Alevtinka28
Alevtinka28
23.06.2020 17:37 •  Информатика

Составить программу на паскале с цикла с неизвестным числом повторений. "на первый же день появления красавца васи в колледже в него влюблялись 2 девочки. с каждым днем их число увеличивалось в два раза, но каждую неделю 23 девочки разочаровывались в нем и влюблялись в сережу. через сколько дней в васю влюбятся 45 девочек? "

Показать ответ
Ответ:
ruslankira11234
ruslankira11234
03.10.2020 18:17
Var k,n:integer;
begin
n:=1;
k:=2;
while k<=45 do
 begin
 n:=n+1;
 k:=k*2;
 if n mod 7 = 0 then k:=k-23;
 end;
writeln('n = ',n,' k = ',k);
end.

Результат:
n = 6 k = 64
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота