В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Составить программу на паскале: заполнить массив вм случайными числами из диапазона от 1 до 150. размерность массива 20.распечатать массив на экране в строку. найти сумму всех нечётных чисел массива. результат вывести на экран в отдельной строке.

Показать ответ
Ответ:
vadim2556
vadim2556
09.10.2020 23:10
program n_1; const  n = 20; var  a: array [1..n] of integer;  i, sum: integer; begin  sum := 0;  for i := 1 to n do    begin    a[i] := random(150) + 1;    write('a[', i, '] = ', a[i], '; ');    if odd(a[i]) then inc(sum, a[i]);    end;  writeln ();  write('sum = ', sum); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота