В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
nastyaturchina
nastyaturchina
22.08.2022 14:50 •  Информатика

Составить программу на С++ Создайте массив из 10 ячеек числа введите на клавиатуре от 1 до 10.Выполняя сортировку выбором.​

Показать ответ
Ответ:
nbillier2004gmailcom
nbillier2004gmailcom
11.01.2021 21:16

#include <iostream>

using namespace std;

int main() {

int a[10],size=10,min,temp;

for (int i = 0; i < 10; i++) {

 cin >> a[i];

}

 

for (int i = 0; i < size - 1; i++) {

 min = i;

 for (int j = i + 1; j < size; j++) {

  if (a[j] < a[min]) {

   min = j;

  }

  temp = a[i];

  a[i] = a[min];

  a[min] = temp;

 }

}

for (int i = 0; i < 10; i++) {

 cout << a[i] << " ";

}

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота