В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
kydyrali610
kydyrali610
02.09.2020 09:04 •  Информатика

Составить программу на яп паскаль, которая бы при генератора сч [напомню, это ф-ции randomize и random(i)] позволяла бы сыграть с пк в игру «угадай число» при виртуальной игральной кости. счёт ведётся до 10 набранных очков. если угадал – плюс одно очко, не угадал – счёт не меняется. счет вести и для игрока и для пк.

Показать ответ
Ответ:
mustafina1990
mustafina1990
11.06.2020 09:55

program game;

var
costi, me, comp, myscore, compscore, round: integer;

begin
randomize;
costi := random(6);
myscore := 0;
compscore := 0;
for round := 1 to 10 do
begin
writeln('Введите ваще число от 1 до 6');
readln(me);
if me = costi then
writeln('Выпало число ', costi, '. Вы угадали, счет становится (', myscore + 1, ';', compscore,')')
else writeln('Выпало число ', costi, '. Вы не угадали, счет остается преждним (', myscore, ';', compscore,')');
if me = costi then myscore := myscore + 1;
writeln('Кости бросает компьютер');
costi := random(6);
comp := random(6);
if comp = costi then
writeln('Выпало число ', costi, '. Компьютер угадал, счет становится (', myscore, ';', compscore + 1,')')
else writeln('Выпало число ', costi, '. Компьютер не угадал, счет остается преждним (', myscore, ';', compscore,')');
if comp = costi then compscore := compscore + 1;
end;
if myscore>compscore then writeln ('Вы победили!');
if myscore<compscore then writeln ('Вы проиграли.');
if myscore=compscore then writeln ('Боевая ничья!');
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота