В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Составить программу на языке Basic. Задание: Составить таблицу стоимости порций сыра весом 50, 100,
150,……1000 г. (Цена 1 кг сыра 270 р.)

Показать ответ
Ответ:
Вилка000
Вилка000
11.07.2022 01:48

C#

string a;

           ConsoleKeyInfo keyInfo;

           do

           {

               Console.WriteLine("Введите одну из перечисленных стран:\n*Венгрия\n*Италия\n*Греция\n*Турция\n*Египет\n*Непал\n*Бельгия\n");

               a = Convert.ToString(Console.ReadLine());

               switch (a)

               {

                   case ("Венгрия"):

                       Console.WriteLine("Столица: Будапешт\nНаселение: 9,7 млн чел.\n");

                       break;

                   case ("Италия"):

                       Console.WriteLine("Столица: Рим\nНаселение: 60 млн чел.\n");

                       break;

                   case ("Греция"):

                       Console.WriteLine("Столица: Афины\nНаселение: 10 млн чел.\n");

                       break;

                   case ("Турция"):

                       Console.WriteLine("Столица: Анкара\nНаселение: 55 млн чел.\n");

                       break;

                   case ("Египет"):

                       Console.WriteLine("Столица: Каир\nНаселение: 53 млн чел.\n");

                       break;

                   case ("Непал"):

                       Console.WriteLine("Столица: Катманду\nНаселение: 29 млн чел.\n");

                       break;

                   case ("Бельгия"):

                       Console.WriteLine("Столица: Брюссель\nНаселение: 11 млн чел.\n");

                       break;                    

                   default:

                       Console.WriteLine("Неверно введены данные\n");

                       break;

               }    

               

               Console.WriteLine("Если хотите повторить программу нажмите F");

               Console.WriteLine("Если хотите завершить программу нажмите любую другую кнопку\n");

               keyInfo = Console.ReadKey(true);

           }

           while (keyInfo.Key == ConsoleKey.F);


2. Напишите программу, которая при наборе с клавиатуры названия страны выводит на экран название сто
0,0(0 оценок)
Ответ:
crisisd
crisisd
30.04.2022 10:40

C#

int a;

           ConsoleKeyInfo keyInfo;

           do

           {

               Console.WriteLine("Введении один порядковый номера пальца руки:\n1, 2, 3, 4, 5");

               a = Convert.ToInt32(Console.ReadLine());

               switch (a)

               {

                   case 1:

                       Console.WriteLine("Большой\n");

                       break;

                   case 2:

                       Console.WriteLine("Указательный\n");

                       break;

                   case 3:

                       Console.WriteLine("Средний\n");

                       break;

                   case 4:

                       Console.WriteLine("Безымянный\n");

                       break;

                   case 5:

                       Console.WriteLine("Мизинец\n");

                       break;

                   default:

                       Console.WriteLine("Такого пальца нет\n");

                       break;

               }    

               

               Console.WriteLine("Если хотите повторить программу нажмите F");

               Console.WriteLine("Если хотите завершить программу нажмите любую другую кнопку\n");

               keyInfo = Console.ReadKey(true);

           }

           while (keyInfo.Key == ConsoleKey.F);


1. Напишите программу, которая при введении порядко вого номера пальца руки выводит его название на
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота