В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
denis2016sham
denis2016sham
12.09.2021 23:38 •  Информатика

Составить программу на языке c++! дано натуральное число n. выведите слово yes, если число n является точной степенью двойки, или слово no в противном случае. операцией возведения в степень пользоваться нельзя!

Показать ответ
Ответ:
oles2014
oles2014
07.10.2020 06:09
#include <bits/stdc++.h>
using namespace std;
int main(){

int n;
cin >> n;
if (n <= 0)
{
    cout << "NO";
    return 0;
}
while (n % 2 == 0)
{
n = n / 2;
}
if ( n == 1)
    cout << "YES";
else
    cout << "NO";
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота