В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
aleksandr250804
aleksandr250804
27.01.2022 10:25 •  Информатика

Составить программу на языке Pascal для нахождения гипотенузы с и площади S прямоугольного треугольника, если известны его катеты а и в (тремя : обычная линейная программа, программа с использованием процедуры и программа с использованием функции)

Показать ответ
Ответ:
Aleks5953
Aleks5953
01.01.2022 21:24

var

 a,b,s,c:real;

begin

 write('a b:');readln(a,b);

 c:=sqrt(sqr(a)+sqr(b));

 S:=a*b/2;

 writeln('c:',c,', S:',S);

end.

var

 a,b,s,c:real;

procedure Sc(var a,b:real);

 begin

   c:=sqrt(sqr(a)+sqr(b));

   S:=a*b/2;

   writeln('c:',c,', S:',S);

 end;

begin

 write('a b:');readln(a,b);

 Sc(a,b);

end.

var

 a,b,s,c:real;

function Sss(var a,b:real):real;

 begin

   Sss:=a*b/2;

 end;

function Ccc(var a,b:real):real;

 begin

   Ccc:=sqrt(sqr(a)+sqr(b));

 end;

begin

 write('a b:');readln(a,b);

 S:=Sss(a,b); c:=Ccc(a,b);

 writeln('c:',c,', S:',S);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота