В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
tumenka140
tumenka140
04.10.2020 18:12 •  Информатика

Составить программу на языке pascal! все . найти произведение и количество всех целых чисел, расположенных между двумя заданными числами + блок схема. заранее )

Показать ответ
Ответ:
2001kirik
2001kirik
26.03.2021 09:12
Const
  nn=50; // максимальное количество учеников
var
  i,n,sm,sd,km,kd:integer;
  am,ad:real;
  var a:array[1..nn] of integer;
begin
  Write('Введите количество учеников: ');
  Read(n);
  Writeln('Введите рост учеников');
  sm:=0; sd:=0; km:=0; kd:=0;
  for i:=1 to n do
    begin
    Read(a[i]);
    if a[i]>0 then begin sd:=sd+a[i]; Inc(kd) end
    else begin sm:=sm-a[i]; Inc(km) end
    end;
  am:=sm/km; ad:=sd/kd;
  Write('Средний рост мальчиков (',am:0:1,') ');
  if am-ad<=10 then Write('не ');
  Writeln('превышает средний рост девочек (',ad:0:1,') ');
  Writeln('больше, чем на 10 см')
end.
   
Примерное решение

Введите количество учеников: 9
Введите рост учеников
-192 165 -174 179 -172 171 169 170 -170
Средний рост мальчиков (177.0) не превышает средний рост девочек (170.8)
больше, чем на 10 см
0,0(0 оценок)
Ответ:
Voproshayka
Voproshayka
17.01.2021 19:49

Расстояние между экраном и глазами должно быть не менее 45 сантиметров. После каждых 40 минут, проведённых за компьютером, необходимо делать пятнадцатиминутный перерыв, смотреть вдаль, делать гимнастику для глаз. Яркость экрана должна быть оптимальной для глаз, контраст должен быть сбалансированным.

В комнате, где вы работаете, должно быть правильное освещение, свет должен падать с левой стороны. После яростного печатания на клавиатуре лучше всего делать пальчиковую гимнастику, сжимать и разжимать пальцы.

Следите, чтобы дыхание во время работы было естественным, не затаённым. Воздух в комнате должен быть свежим и чистым.

Прекращайте работу при малейших признаках утомления.

После каждого часа работы за компьютером должна быть физическая активность - прогулка,  игра в мяч на улице.

Яркое и неровное освещение в комнате может вызвать блики на экране. Принимайте меры в связи с этой информацией.

Запрещается много играть в компьютерные игры и видеоигры, особенно ночью.

Если отметь этот ответ, как лучший

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота