В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
sasha123123476
sasha123123476
23.09.2020 17:23 •  Информатика

Составить программу на языке паскаль : дана матрица а(n, n). составить программу подсчета количества положительных элементов, расположенных выше главной диагонали

Показать ответ
Ответ:
makc369
makc369
12.07.2020 13:55
Var n, i, j, ans : integer;
a : array[,] of integer;
begin
    read(n);
    ans := 0;
    SetLength(a, n + 1, n + 1);
    for i := 1 to n do
        for j := 1 to n do
            read(a[i, j]);
    for i := 1 to n do
        for j := i + 1 to n do
            if (a[i, j] > 0) then
                ans := ans + 1;
    writeln(ans);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота