В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Apple8066
Apple8066
13.04.2023 10:59 •  Информатика

Составить программу на языке паскаль, для решения : 1".зная цену компьютера b рублей,определить хватит ли покупателю на a рублей купить компьютер? " 2."зная длину забора d метров,определить хватит ли сетки а метров.чтобы обнести этот забор"?

Показать ответ
Ответ:
жека0262
жека0262
13.08.2020 15:33
1)
var
a,b,e:real;
begin
write('Сколько стоит компьютер - ');
readln(b);
write('Сколько денег у покупателя - ');
readln(a);
e:=a-b;
if e>0 then
 writeln('Покупателю хватит денег на покупку компьютера ценой - ',b,'руб.')
else
 begin
  e:=e*(-1);
  write('Покупатель не сможет купить компьютер ценой - ',b,'руб. Ему не хватает - ',e,'руб.');
 end;
end.
2)
var
a,b,e:real;
begin
write('Длина забора (м) - ');
readln(b);
write('Длина сетки (м) - ');
readln(a);
e:=a-b;
if e>0 then writeln('Сетки хватит чтобы обнести забор.')
else
 begin
  e:=e*(-1);
  write('Сетки не хватит чтобы обнести забор.');
 end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота