В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
KOROTKOVAKATA
KOROTKOVAKATA
04.09.2021 12:09 •  Информатика

Составить программу на языке Паскаль для решения следующей задачи: Дан одномерный массив. В массиве хранятся оценки по информатике учеников 9 класса. Заполнить массив случайными числами, лежащими в диапазоне от 2 до 5 включительно. Вычислите среднюю оценку в классе по информатике. Входные данные для размерности массива задайте самостоятельно.

На проверку нужно прислать текст кода программы, результат работы кода в виде скриншота окна программы с отображением кода и полученного результата. Программная реализация обязательна!

Показать ответ
Ответ:
rran
rran
26.02.2022 17:30

Программа:

Pascal:

var

 arr: array of integer;

 n, i, sum: integer;

begin

 write('Количество учеников: '); readln(n);

 SetLength(arr, n);

 

 for i := 0 to n - 1 do begin

   arr[i] := random(2, 5);

   sum += arr[i];

 end;

 writeln('Оценки учеников в классе: ', arr);

 writeln('Средняя оценка: ', sum/n);

end.

Для начала выделяем память массиву целых чисел, после - регистрируем переменные, которые будем использовать далее. Запрашиваем кол-во учеников (это и будет размерностью массива), устанавливаем длину массива - введённое число n. Циклом проходима по элементам массива, устанавливаем рандомное значение от 2 до 5 и суммируем элементы. В конце выводим сам массив и высчитываем среднюю оценку как среднее арифметическое чисел.


Составить программу на языке Паскаль для решения следующей задачи: Дан одномерный массив. В массиве
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота