В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Составить программу на языке паскаль которая меняет местами два числа без ввода дополнительной ячейки

Показать ответ
Ответ:
Elka29677
Elka29677
31.08.2020 07:23
A:=a+b;
b:=a-b;
a:=a-b;

var a,b:real;
procedure change(var a, b: real);
begin
a := a + b; writeln(a);  
b := a - b; writeln(b);  
a := a - b; writeln(a);
end;
begin
writeln('a, b:');  
readln(a, b);  
writeln('a=', a);  
writeln('b=', b);  
change(a, b);  
writeln('a=', a);  
writeln('b=', b);  
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота