В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
tanyakozina00
tanyakozina00
15.05.2023 03:24 •  Информатика

Составить программу на языке паскаль, которая запрашивает у пользователя некоторое количество трехзначных чисел и выводит на экран цифру, находящуюся в середине каждого полученного числа. не в коем случае не используй их: last, const, count. делай обыкновенным

Показать ответ
Ответ:
albina236
albina236
16.08.2020 21:00
Var i, x, y: integer;

a: array [1..255] of integer;
function sr(i: integer):string;

begin

sr:=inttostr(i)[2];

end;
begin

writeln('Vvedite kol-vo chisel');

read(x);

for i:=1 to x do read(a[i]);

writeln();

for i:=1 to x do writeln(sr(a[i]));

end.
0,0(0 оценок)
Ответ:
averinael2013
averinael2013
16.08.2020 21:00
Program n_5;
var
   a, b, c: real;
procedure n_1;
begin
 if ((a<b) and (a>c)) or ((a<c) and (a>b)) then
  write (a)
 else
  if ((b<a) and (b>c)) or ((b<c) and (b>a)) then
   write (b)
  else
   if ((c<a) and (c<b)) or ((c<b) and (c>a)) then
    write (c);
end;
begin
 writeln ('Введите три трёхзначных числа');
 readln (a);
 readln (b);
 readln (c);
 if ((a >= 100) and (a <= 999) and (a <> b) and (a <> c)) and ((b >= 100) and (b <= 999) and (b <> a) and (b <> c)) and ((c >= 100) and (c <= 999) and (c <> a) and (c <> b)) then n_1
 else
  write ('ERROR');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота