В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
kornev183
kornev183
04.03.2023 03:25 •  Информатика

СОСТАВИТЬ ПРОГРАММУ НА ЯЗЫКЕ ПАСКАЛЬ нужна Составить программу. Из 800 учащихся школы на данный момент посещают школу N человек. Определить, через сколько дней число посещающих школу составит менее половины учащихся школы, если число не больных школьников каждый день уменьшается на 10% от предыдущего дня.

Показать ответ
Ответ:
151020071
151020071
13.10.2020 02:25

var n,k:integer;

begin

repeat

write('Введите количество не больных школьников от 401 до 800 n=');

readln(n);

until(n>400)and(n<=800);

k:=0;

while n>400 do

begin

 n:=round(n*0.9);

 k:=k+1;

end;

write('Через ',k,' дн. ',' количество учащихся составит менее половины = ',n);

end.

взял отсюда: https://studassistent.ru/pascal-abc/opredelit-cherez-skolko-dnej-chislo-poseshhayushhikh-shkolu-sostavit-menee-poloviny-uchashhikhsya-shkoly-pascal-abc

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота