В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Zoya20060609
Zoya20060609
05.06.2020 20:32 •  Информатика

Составить программу на языке Паскаль. Ввести массив из 12 целых чисел. Вставить в него число В
перед последним элементом. Число В ввести случайным образом. Полученный массив вывести на
экран.

Показать ответ
Ответ:
Amy1503
Amy1503
08.05.2020 15:30

1) Program Massiv1;

    Uses Crt;

    var k:array[1..12] of real;

           i,c:integer;

begin

     clrscr;    

     write('Введите элементы массива k:');

     c:=0;   

     for i:=1 to 12 do

        begin 

            readln(k[i]);

            if (k[i]<0) then Inc(c);

 

     end;

 

   writeln;

    writeln;  

 for i:=1 to 12 do write(k[i]:4:4);

 writeln;  

  writeln('Количество элементов <0:',c); 

  readkey;      

end.   

 

 

 

2) Program Massiv2;

    Uses Crt;

    var m:array[1..10] of integer;

         i,c:integer;

begin

     clrscr;    

     write('Введите элементы массива m:');

     c:=0;   

     for i:=1 to 10 do

        begin 

            readln(m[i]);

            if (m[i]=3) then Inc(c);

     end;

   writeln;

    writeln;  

 for i:=1 to 12 do write(m[i]:4);

 writeln;  

  writeln('Количество элементов =3:',c); 

  readkey;      

end.   

 

В третьем задании  видимо имеется ввиду номер элемента этого массива, т.к по условию задачи массив у нас один.

 

 

 3) Program Massiv3;

    Uses Crt;

    var m:array[1..8] of integer;

           i,c,max:integer;

begin

     clrscr;    

     write('Введите элементы массива m:');

     c:=0;   

     for i:=1 to 8 do  readln(m[i]);

   writeln;

   writeln;  

 max:=m[1] 

 for i:=1 to 8 do

   begin

        if  (m[i]>max) then

                    begin

                         max:=m[i];

                         c:=i 

                   end;        

        write(m[i]:4); 

end;

  writeln('Индекс максимального элемента =:',c); 

  readkey;      

end.   

 

4) Program Massiv4;

    Uses Crt;

    var m:array[1..12] of integer;

           i,c,max,sum:integer;

begin

     clrscr;    

     write('Введите элементы массива m:');

     c:=0; sum:=0;   

     for i:=1 to 12 do  readln(m[i]);

   writeln;

   writeln;  

 max:=m[1] 

 for i:=1 to 12 do

   begin

        if  (m[i]>max) then

                    begin

                         max:=m[i];

                         c:=i 

                   end;        

        write(m[i]:4);  

end;

for i:=1 to c-1 do sum:=sum+m[i];

 writeln('Количество элементов расположенных до max :',с-1); 

 writeln('Сумма элементов расположенных до max :',sum); 

 readkey;      

end.   

 

 В пятом задании  видимо имеется ввиду значения элементов массива меньшие чем сумма первого и последнего

 

 

 

5) Program Massiv5;

    Uses Crt;

    var k:array[1..15] of real;

           sum:real;

           i,c:integer;

begin

     clrscr;    

     write('Введите элементы массива k:');

     c:=0;   

     for i:=1 to 15 do   readln(k[i]);

  sum:=k[1]+k[15];       

   writeln;

   writeln;  

 for i:=1 to 15 do

     begin

          write(k[i]:4:4);

           if  (k[i]<sum) tnen Inc(c); 

         end;

 writeln;  

  writeln('Количество элементов :',c); 

  readkey;      

end.   

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота