В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Асечка05
Асечка05
20.05.2023 03:45 •  Информатика

Составить программу на языке паскаль ввести с клавиатуры вещественное число a и целое число n (> 0). вывести все целые степени числа a от 1 до n.

Показать ответ
Ответ:
MILAVASSILYEVA
MILAVASSILYEVA
26.08.2020 21:08
Var a,an:real; n,i:integer;
begin
readln(a,n);
an:=1;
for i:=1 to n do
 begin
 an:=an*a;
 writeln(a:3:2,'^',i,' = ',an:6:3);
 end;
end.

Пример:
2.0 5
2.00^1 = 2.000
2.00^2 = 4.000
2.00^3 = 8.000
2.00^4 = 16.000
2.00^5 = 32.000
0,0(0 оценок)
Ответ:
57788
57788
26.08.2020 21:08
Var
    a: real; 
    n: integer;
begin
    read(a, n);
    for var k := 1 to n do
    begin
        write(power(a, k), ' ');
    end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота