В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Настя2017465
Настя2017465
02.03.2021 05:50 •  Информатика

Составить программу на языке паскаль: вычислить значение выражения: f(x)=ctg 3x*log(2x+3)*4 при любых значениях х

Показать ответ
Ответ:
tisha199567
tisha199567
09.09.2020 16:28
Первый вариант: если десятичный логарифм от (2x+3).

Var X:real;
Begin
Write('x = ');ReadLn(x);
if x<=-1.5 then WriteLn('Ошибка: Нельзя вычислить логарифм от нуля!')
else if x = 0 then WriteLn('Ошибка: На ноль делить нельзя!')
     else WriteLn('f(',x,') = ',Ln(2*x+3)*4/(Tan(3*x)*Ln(10)))
End.

Второй вариант: если логарифм по основанию (2x+3) от 4.

Var X:real;
Begin
Write('x = ');ReadLn(x);
if x<=-1.5 then WriteLn('Ошибка: Основание логарифма должно быть больше нуля!')
else if x = 0 then WriteLn('Ошибка: На ноль делить нельзя!')
     else WriteLn('f(',x,') = ',Ln(4)/(Tan(3*x)*Ln(2*x+3)))
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота