В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
livekristinka
livekristinka
20.03.2022 08:47 •  Информатика

Составить программу на языке паскаля: даны числа a,b,c. составить программу, выводящую на экран сообщение, в зависимости от того какой треугольник можно построить с такими длина сторон:
равносторонний,равнобедренный или какой либо другой.

Показать ответ
Ответ:
мидина5
мидина5
24.05.2020 13:09

var a,b,c: integer;

begin

  readln(a,b,c);

  if (a>b+c) or (b>a+c) or (c>a+b) then begin writeln('Треугольник не сущесвует'); exit; end;

  if (a=b) or (b=c) or (a=c) then writeln('Равнобедренный треугольник');

  if (a=b) and (b=c) and (a=c) then writeln('Равносторонний треугольник');

  if (sqr(c)=sqr(a)+sqr(b)) or (sqr(b)=sqr(c)+sqr(a)) or (sqr(a)=sqr(b)+sqr(c)) then writeln('Прямоугольный треугольник');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота