В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Sold5561
Sold5561
10.01.2020 11:28 •  Информатика

Составить программу на языке с++, которая решает задачу: Вычислить значение функции y=3x при х<10.3, y=2x, при x>=10.3

Показать ответ
Ответ:
Floren255
Floren255
15.09.2020 06:30

Кодяра:

#include <iostream>

double F(double x) {

   if (x < 10.3)

       return 3*x;

   else

       return 2*x;

}

void print_f(double x) {

   std::cout << "x=" << x << "; F(x)=" << F(x) << std::endl;

}

int main() {

   for (double x = 5; x < 15; x += 4.3)

       print_f(x);

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота