В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Составить программу на языке С++, решающую следующую задачу: Дано трехзначное число.
Найти сумму и произведение его цифр.

Показать ответ
Ответ:
dilpiztalipova
dilpiztalipova
28.08.2020 16:35

#include <iostream>

int main()

{

int N, s1 = 0, s2 = 1;

setlocale(LC_ALL, "Russian");  // Русский язык в консоли

std::cin >> N;

while (N > 0)

{

 s1 += N % 10;

 s2 *= N % 10;

 N /= 10;

}

std::cout << "Сумма: " << s1 << std::endl;

std::cout << "Произведение: " << s2;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота