В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
GetMaths
GetMaths
25.10.2021 06:06 •  Информатика

Составить программу на языке си известны год и номер месяца рождения человека. определить возраст человека на март(3 месяц) 2008 года

Показать ответ
Ответ:
Igor20018
Igor20018
05.10.2020 03:23
#include <stdio.h>

int main() {
 int year, month, cur_y = 2008, cur_m = 3, m_age, y_age;
 scanf("%d%d", &year, &month);
 if(month - cur_m > 0) {
   m_age = 12 - (month - cur_m);
   y_age = (cur_y - year) - 1;
  } else {
    m_age = cur_m - month;
    y_age = cur_y - year;
  }
  printf("%d years and %d months\n", y_age, m_age);
  return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота