В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
anablack1
anablack1
12.11.2022 14:09 •  Информатика

Составить программу на языке Составить программу нахождения минимального элемента и его номера в массиве вещественных чисел не более 40, задаваемых вводом с клавиатуры.
2. Сформировать массив (вывести на экран) из т случайных целых чисел на промежутке от -60 до 60, найти сумму чисел больших 20.

Показать ответ
Ответ:
yaaaaaaan
yaaaaaaan
11.06.2020 22:37
Потому, что сообщение состоит из символов. Все символы входят в алфавит и могу кодироваться разным числом байт в зависимости от мощности алфавита и! правила кодирования. Есть однобайтовые кодировки, есть двухбайтные. В utf-8 символ может быть записан в 1 до 7 байт, т.е в одном сообщении символы разной длины.

Т,О, просто по коду мы не можем получить мощность алфавита и кодирования => и объем информации.

Но в некоторых случаях в начале двоичного сообщения вставляют преамбулу, по которой можно все узнать 
0,0(0 оценок)
Ответ:
Adilkin
Adilkin
31.01.2021 19:10
uses crt; var s:string;     c:char;     m:set of char;     n,i,k,p:byte; begin writeln('Введите текст из строчных латинских букв, окончаание ввода Enter'); s:=''; repeat c:=readkey; if c in ['a'..'z'] then  begin   write(c);   s:=s+c;  end; if c=#13 then writeln until c=#13; n:=length(s); m:=[]; for c:='a' to 'z' do  begin   k:=0;   for i:=1 to n do   if s[i]=c then k:=k+1;   if k>1 then m:=m+[c];  end; if m=[] then write('Нет букв, встречающихся более 1 раза') else  for c:='a' to 'z' do  if c in m then write(c) end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота