В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
MrVyacheslav228
MrVyacheslav228
28.08.2021 09:03 •  Информатика

Составить программу нахождения модуля n-мерного радиус-вектора
Qbasic
Очень

Показать ответ
Ответ:
Dirolling
Dirolling
01.03.2021 02:47

1)var

a:array[1..5]of integer;

i,n,s:integer;

begin

 writeln('Введите кол-во элементов');

 readln(n);

 writeln('Введите число');

 s:=0;

 for i:=1 to n do begin

   read(a[i]);

   if a[i]>0 then s:=s+a[i]

 end;

 writeln('Сумма положительных элементов массива равна ', s)

end.

2)var

a:array[1..10]of integer;

i,n,P:integer;

begin

 writeln('Введите число элементов');

 readln(n);

 writeln('Введите число');

 P:=1;

 for i:=1 to n do begin

   read(a[i]);

   if a[i] mod 6 = 0  

   then P:=P*a[i]

 end;

 writeln('Произведение элементов массива кратных 6 равна ',P)

end.

3)var

a:array[1..5]of integer;

n,i:integer;

begin

 writeln('Введите кол-во элементов');

 readln(n);

 writeln('Введите число');

 for i:=1 to n do begin

   read(a[i]);

   if a[i]>0 then begin

   a[i]:=a[i]*3;

   writeln('Новый элемент равен: ',a[i])

 end;

 if a[i]<=0 then begin

   a[i]:=a[i]+5;

    writeln('Новый элемент равен: ',a[i])

 end;

 end;

end.

Буду рад если отметишь мой ответ как лучший

0,0(0 оценок)
Ответ:
Lolilolokigh
Lolilolokigh
13.08.2021 11:57

Машинная память работает по принципу 0 и 1, т. е. 0 это нету сигнала, 1 это есть сигнал. По этому для понимания мы может просто записывать это в таблицу.

К примеру возьмём 2 клетки. Если и первая клетка и вторая равна 1, тогда выполняется что то одно, если не равны, то что то другое.

На самом компьютере да и вообще любом современном электронном устройстве всё работает по этому же принципу, только вместо таблицы с 0 и 1, используется "Есть питания" или же "Нету питания", поступил ток по нужному проводу или нет.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота