В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
RUStepan5
RUStepan5
14.10.2020 00:17 •  Информатика

Составить программу нахождения наибольшего общего делителя нескольких чисел, используя функцию нахождения НОД двух чисел.

Показать ответ
Ответ:
азат61
азат61
25.02.2021 23:17

program HomeWork;

var a,b,c: integer;

begin

 write('Введите два целых числа через пробел: '); readln(a, b);

 c := a mod b;

 while c <> 0 do

 begin

   a := b;

   b := c;

   c := a mod b;

 end;

 write(b)

end.

0,0(0 оценок)
Ответ:
Nusyaa
Nusyaa
25.02.2021 23:17

Паскаль. Вычисляет НОД для любого кол-ва чисел

Объяснение:

function Nod(a,b:integer):integer;{определение НОД двух чисел}

begin

while a<>b do

if a>b then a:=a-b else b:=b-a;

Nod:=a;

end;

var

   a: array of integer;

   n, i: integer;

   k: integer;

begin

 WriteLn('*** Определение НОД нескольких чисел ***');

 Write('Введите кол-во чисел N = '); ReadLn(n);

 SetLength(a, n + 1);

 WriteLn('Введите числа: ');

 for i := 1 to n do

  begin

   Write(i,'-e число: '); ReadLn(a[i]);

  end;

 WriteLn;

 k := Nod(a[1], a[2]);

 for i := 3 to n do k := nod(k, a[i]);

 WriteLn('Общий НОД всех чисел = ', k);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота